BMDビデオI/Oから音が出なくなった

使用したのは、UltraStudio4K、少し前のモデルのUltraStudio Expressでした。出なかった音声と言うのは、アナログとAES系統だけだったのです。SDIオーディオはビデオと共に正常に出ていて、これまでに遭遇したことがなかった現象でした。

考えられる原因は?

いくつかの確認するポイントがあります。まずは、macOSのバージョンです。今回は直近にクリーンインストールを実施したので、この部分が最も原因としては怪しいです。以前までのバージョンが10.12.6で今回入れたのが10.14.6でした。二世代前のメジャーバージョンからのアップデートでした。私の好みでは10.15.7にしたかったのですが、システム全体の事情で一つ前の最終バージョンにしておいた次第です。macOSが怪しいので、私のMacBook Pro(10.15.7)をThunderboltで接続して試したところ、同じ現象が出てmacOSのバージョンには依存していない様子です。

次に試したのは、Blackmagic DesignのDesktopVideoのバージョンダウンです。こんな時のためにBlackmagic Design社は過去のバージョンも結構古いものまで残してくれているのが嬉しい対応です。結果的にはこれも効果がありませんでした。残るは使用していたAdobe CCの中のPremiere Pro最新版です。やはり自分はPremiere Proとは相性が良く無いのか?なんて考え始めて、諦めムードが漂い始めました。

原因と対策は

原因は過去のPremiere Proの初期設定ファイルを読み込んでしまったことが良くなかったようです。そのシステムでは、Premiere Proの不具合への対策として、初期設定などの関連ファイルをサクッと削除/更新するようなスクリプトを使っていました。過去の10.12.6の時に使っていたリセットスクリプトを、10.14.6でもかけてしまい過去の初期設定をロードしたことが、オーディオ出力が出来なくなった原因のようでした。ただ、初期設定を更新するだけでは不具合は治らなくて、下記のような手順を踏むことになりました。これを見つけるのに苦心しました。

・システム環境設定から、Blackmagic Desktop Video Setupを起動
・ツールの設定をするために画面を進める
・Audioタブに切り替える
・その中の、AESとAnalogの出力レベルを一旦デフォルトよりも高くする
・Saveをかけてツールを終了する
・直後に再度ツールを起動して、先のレベルをリセット
・レベルがすべてデフォルトに戻っていることを確認してSaveして終了

以上です。要するに、アナログレベルとデジタルレベルの音量を変更してSaveします。これでは適正なレベルで運用できないので、直ちにリセットして保存しなおします。一連のこの操作によって、デフォルトのオーディオレベルがリセット保存されて書き直されるのでしょう。

今回の不具合はPremiere Proとの関連のようで、DaVinci Resolveでも同じ問題が出るかは未確認です。私の経験からは多分それは無いだろうとは思います。また、他のmacOSのバージョン、Premiere Proのバージョンでは未確認です。同じような現象に遭遇した方は試してみてください。正直この対策方法は偶然見つかったので、運が良かっただけだと思います。なかなか見つけにくい対策なので、ホッと胸を撫で下ろしているところです。

「BMDビデオI/Oから音が出なくなった」への2件のフィードバック

  1. 同じ環境ではありませんがPremiere(2020)とUltraStudio 4K Extreme 3の組み合わせでXLRオーディオ出力されません
    HDMI音声は生きています(なので接続しているテレビからモニターへ出力)

  2. 記事には書き忘れましたが、この現象はMedia Expressでも発生していました。藤原さんの現象と似ているので、根っこは同じかもしれませんね。

コメントを残す

メールアドレスが公開されることはありません。

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください